Texture option missing in painting settings

Hi, I cannot add a texture image when I want to use it for vertex paint, the option is missing.

This is how it should look like (took a screenshot from a video in another forum topic):

This is how I have it:

Tried searching the manual and forum if the texture option has moved but with no result, so I reckon it’s either I’m missing something or it’s a bug.


Thanks! The solution was in front of me…like searching for butter in a fridge.