Does not open anymore on chromeOS

Since the last update the app now closes immediately when opening on chromeOS

A chromeOS update? Nomad last release was 1 month ago

I have the same problem! Exactly the same thing happens when I start the app. Have not used it for a couple of weeks and I tried to open the app yesterday. It did not work. I then updated the app and also my ChromeOs but still not working.

Does it work once after restarting the ChromeOS device?

I have a similar issue in DEX (but not as bad): Trying to come back from inactive state (after clicking X) force closes Nomad after the screen flashes grey shortly.

After the force close, it starts normally so I basically I just have to start it two times.

In Non DEX mode it starts normally everytime, maybe it has to do with that it’s trying to start in a window

The chromeOS issue might come from the x86_64 Nomad build.
Chromebook are really annoying, ton of issue with it.

My initial guess is it drops the OpenGL context although I specifically stated that I want to keep it (if it can’t keep it then the app restarts). There is no guarantee though.
I’m not sure that’s the issue though.

If there is anything you want me to test, let me know.

I tried starting/opening it twice, reboot chromeOS, uninstall and installing the app, updating chromeOS.

It’s my daugther’s chroombook. She loves the app and hopes she can use it again :slight_smile: She’s 8 years old.

1 Like

Can you tell me what device you have (mostly I want to know if it’s intel or arm).

I do have something in mind, I can do an internal test.
If I do I’ll ask you your google play email (and then you should receive an invite or something, to test a special build)

I can confirm the issue is what I said just earlier, it’s a context lost (DEX only frees VRAM, not the RAM).
It will work on next Nomad release. Recovering from context gl can be tricky so maybe there’ll be some remaining issues.

Ah Thanks! I noticed in GPUWatch it closes when trying to use the same API id as before.

I’ll check for any funky stuff that happens once it’s out.

It’s a Intel based Lenovo IdeaPad Flex 5GB 13iML05

The app is not open for some time now. I’ve been meaning to open a ticket here but was a bit busy. It was definitely the app update.

My machine is a Intel EVO i5 12th gen.

Here is my backtrace for the crash on startup for Intel ChromeOS, I’ve tried on both stable and dev channels. I’ve powerwashed my chromebook, and reset it to default as well, to test this.

I’ve attached a full stack trace of the crash, you can open it in a text editor. I’ve also reported the crash to google. This appears to be to a ChromeOS change.

To reproduce take a fresh chromebook, and install Nomad Sculpt, and try to launch it, it will crash immediately.

tombstone_15 (310.3 KB)

I did test this on my old slow ARM chromebook, and Nomad Sculpt still starts, but it lags well behind the intel chromeOS releases, so it’s possible that once it catches up to the Intel releases of chromeOS it will also crash at startup.

I also played with the various GPU flags with no luck to see if I could get it to start on my Intel Chrome book.

I have filed this ticket with the ChromeOS team:

1 Like

@stephomi Just to be clear, it sounds like there are two issues that are being discussed in this thread.

One is that the app crashes after the device has come back from being asleep. (This one sounds like you might have a fix for it).

And another which the app is entirely unusable on ChromeOS for Intel, the app always crashes at startup so there’s no way to use the app at all on an Intel Chromebook at the moment.

I realize that this isn’t a bug that you introduced, and it’s due to some change in the operating system.

Anyways if there’s anything else I can do to help get this resolved let me know.

I was in the middle of a bunch of 3D projects and I’m stalled now because I can’t use Nomad sculpt.

I tried a bunch of other 3D apps from the app store, about 20 and only found one other that exhibits similar behavior to Nomad Sculpt - crashing on startup. But I don’t have a way to know if this app worked prior to the recent ChromeOS update.

Generally it seems like this bug is likely related to something specific with the Nomad Sculpt startup sequence.

(I’m still feeling victorious, from crushing a longstanding infrequent file corruption bug in my own software last week. It was caused by a bug in a popular open source library, 80 plus hours have been spent hunting this bug down. I feel your pain)

A Samsung bug, but it should work better on next relese.

The other bug is caused by an openmp call.
I can defer the first call to happen later, but I won’t disable openmp for chromeOS+intel.

Any news on this issue? I really need to use the app for a class.

Should be fixed on next release.

First off, thank you for your work. Nomad is the main app I use daily and I bought it for both android/iOS. I was wondering if there is any update to this? I got a samsung galaxy chromebook today specifically for this application and was pretty disapointed to find that the app just crashes. I have a ton of stuff id like to work on and find it hard to do on my phone. Please let me know if there is any info I can provide to help with this issue. Thanks again, youre amazing! This replaced zbrush for me.

In case anyone needs help with this. I was able to get it to work on my samsung galaxy chromebook. I had to install a different version of chromeos called fydeos. I wasnt expecting much. But it works and im super happy! My old school emr art pen from about 20 years ago is also compatible. The side buttons worked in linux but not in this version but I might make a separate post about that.

Thanks for the update. It opens again, and it even looks more fluid than before!